mac80211: update to 2012-09-07, adds ath9k beacon fixes, mesh/adhoc fixes, and more
[openwrt.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index f977c96..685006b 100644 (file)
@@ -1,15 +1,15 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -77,7 +77,7 @@ endif # build check
+@@ -78,7 +78,7 @@ endif # build check
  endif # kernel Makefile check
  
- # These both are needed by compat-wireless || compat-bluetooth so enable them
+ # These both are needed by 802.11 and bluetooth so enable
 - export CONFIG_COMPAT_RFKILL=y
 +# export CONFIG_COMPAT_RFKILL=y
  
  ifeq ($(CONFIG_MAC80211),y)
  $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-@@ -688,10 +688,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
+@@ -690,10 +690,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
  ifdef CONFIG_COMPAT_KERNEL_2_6_31