gettext-full: use portability header files for byteswapping on non-linux systems
[openwrt.git] / package / libs / gettext-full / Makefile
index 3444e6b..11dc1f5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
-PKG_VERSION:=0.18.1.1
-PKG_RELEASE:=2
+PKG_VERSION:=0.18.2.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
+PKG_MD5SUM:=034c8103b14654ebd300fadac44d6f14
 PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
 
@@ -35,6 +35,9 @@ define Package/libintl-full
 endef
 
 TARGET_CFLAGS += $(FPIC)
+ifneq ($(HOST_OS),Linux)
+  TARGET_CFLAGS += -I$(STAGING_DIR_HOST)/include
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -50,7 +53,7 @@ CONFIGURE_ARGS += \
        --without-emacs
 
 HOST_CONFIGURE_ARGS += \
-       --with-included-libxml
+       --with-included-libxml --without-libxml2-prefix --with-included-libcroco
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include