Re-enable fuse for 2.4 kernels as well (#1346)
[openwrt.git] / package / fuse / Makefile
index 5171b28..5b94174 100644 (file)
@@ -25,7 +25,6 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/fuse/Default
   TITLE:=FUSE
-  DEPENDS:=@LINUX_2_6
   DESCRIPTION:=\
        FUSE (Filesystem in UserSpacE)
   URL:=http://fuse.sourceforge.net/
@@ -35,7 +34,7 @@ define Package/fuse-utils
   $(call Package/fuse/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libfuse +kmod-fuse @LINUX_2_6
+  DEPENDS:=+libfuse +kmod-fuse
   TITLE+= (utilities)
   DESCRIPTION+=\\\
        \\\
@@ -46,11 +45,18 @@ define KernelPackage/fuse
   SUBMENU:=Filesystems
   $(call Package/fuse/Default)
   TITLE+= (kernel module)
-  DEPENDS:=@LINUX_2_6
   DESCRIPTION+=\\\
        \\\
        This package contains the FUSE kernel module.
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  AUTOLOAD:=$(call AutoLoad,80,fuse)
+endef
+
+define KernelPackage/fuse/2.4 
+  FILES:=$(PKG_BUILD_DIR)/lib/fuse.$(LINUX_KMOD_SUFFIX) 
+endef 
+
+define KernelPackage/fuse/2.6
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
 endef
 
@@ -65,6 +71,18 @@ define Package/libfuse
        This package contains the FUSE shared library, needed by other programs.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-kernel-module \
+       --enable-lib \
+       --enable-util \
+       --disable-example \
+       --disable-auto-modprobe \
+       --with-kernel="$(LINUX_DIR)" \
+       --disable-mtab
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                touch configure.in ; \
@@ -72,39 +90,8 @@ define Build/Configure
                touch Makefile.in ; \
                touch include/config.h.in ; \
                touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --enable-kernel-module \
-                       --enable-lib \
-                       --enable-util \
-                       --disable-example \
-                       --disable-auto-modprobe \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --disable-mtab \
-       );
+       )
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
@@ -112,6 +99,8 @@ define Build/Compile
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               AM_CFLAGS="$(TARGET_CFLAGS) -DDISABLE_COMPAT=1" \
+               EXTRA_DIST="" \
                all install
 endef