base-files: various enhancements to network.sh
[openwrt.git] / package / base-files / Makefile
index ff48f5d..6452a3e 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=109
+PKG_RELEASE:=121
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -23,9 +23,6 @@ ifneq ($(DUMP),1)
   ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
     TARGET:=$(TARGET)-$(PROFILE)
   endif
-  ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
-    LIB_SUFFIX:=64
-  endif
 endif
 
 define Package/base-files
@@ -80,9 +77,10 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
 endef
 
-define Build/Compile
+define Build/Compile/Default
 
 endef
+Build/Compile = $(Build/Compile/Default)
 
 define Package/base-files/install
        $(CP) ./files/* $(1)/