base-files: implement -l (--list-backup) sysupgrade parameter to list the files that...
[openwrt.git] / package / base-files / Makefile
index 3635a56..3ba30c3 100644 (file)
@@ -11,11 +11,10 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=141
+PKG_RELEASE:=146
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,12 +55,6 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
-define Package/base-files/config
-config PROCD_INIT
-       bool "Use procd as the init process"
-       default n
-endef
-
 ifneq ($(CONFIG_PREINITOPT),)
 define ImageConfigOptions
        mkdir -p $(1)/lib/preinit