final fix for the profile selection
[openwrt.git] / include / target.mk
index bd3ceb9..1718a86 100644 (file)
@@ -5,6 +5,14 @@
 # See /LICENSE for more information.
 #
 
+
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(1)),y)
+    $(call Profile/$(1))
+    PROFILE=$$(ID)
+  endif
+endef
+
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)