fixes for a few build errors on osx without fink
[openwrt.git] / include / package-ipkg.mk
index ac69128..20d1326 100644 (file)
@@ -63,9 +63,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
+       -find $$(IDIR_$(1)) -name CVS   | $(XARGS) rm -rf
+       -find $$(IDIR_$(1)) -name .svn  | $(XARGS) rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | $(XARGS) rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false