[include] make packages depend on +librt and +libpthread by default if eglibc is...
[openwrt.git] / include / package-defaults.mk
index c349676..37f814d 100644 (file)
@@ -5,8 +5,10 @@
 # See /LICENSE for more information.
 #
 
+PKG_DEFAULT_DEPENDS = +libc +USE_EGLIBC:librt +USE_EGLIBC:libpthread
+
 ifneq ($(PKG_NAME),toolchain)
-  PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),+libc $(filter-out +libc,$(2)))
+  PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS),$(2)))
 else
   PKG_FIXUP_DEPENDS = $(2)
 endif