large improvement for parallel builds. works without V=99 now and without warnings...
[openwrt.git] / include / kernel-build.mk
index 9335e1a..75c2bcf 100644 (file)
@@ -8,10 +8,6 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
-ifneq ($(DUMP),1)
   all: compile
 endif
 
@@ -101,7 +97,7 @@ define BuildKernel
        @$(MAKE) compile
 
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq