tty detect fix
[openwrt.git] / Makefile
index 4947cbf..e5e1f6f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,12 @@ SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
 export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -38,11 +40,11 @@ endif
 export OPENWRTVERSION
 
 ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
-  tmp/.pkginfo: tmpinfo-clean
+  tmp/.pkginfo: FORCE
 endif
 
 ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
-  tmp/.targetinfo: tmpinfo-clean
+  tmp/.targetinfo: FORCE
 endif
 
 ifeq ($(FORCE),)