nuke some unnecessary complexity in the metadata scanning - simply call include/scan...
[openwrt.git] / Makefile
index 447457e..bcbfd56 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,53 +39,25 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
-  tmp/.pkginfo: FORCE
-endif
-
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
-  tmp/.targetinfo: FORCE
-endif
-
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
   world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-ifeq ($(IS_TTY),1)
-  define progress
-       printf "\033[M\r$(1)" >&2;
-  endef
-endif
+tmp/.pkginfo: FORCE
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="pkginfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(shell ls include/package*.mk) include/kernel.mk" SCAN_EXTRA=""
 
-define dumpinfo
-       @mkdir -p tmp
-       @echo -n Collecting package info... 
-       @-for dir in $(1)/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               $(call progress,Collecting package info... $${dir%%/}) \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
-               echo; \
-       done > $@
-       $(call progress,Collecting package info... done)
-       echo
-endef
-
-tmp/.pkginfo:
-       $(call dumpinfo,package)
-
-tmp/.targetinfo:
-       $(call dumpinfo,target/linux)
+tmp/.targetinfo: FORCE
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="$(shell ls include/kernel*.mk)" SCAN_EXTRA=""
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -113,10 +85,16 @@ oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
 menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+kernel_menuconfig: .config FORCE
+       -$(MAKE) target/linux-prepare
+       $(NO_TRACE_MAKE) -C target/linux menuconfig
+
+package/%: 
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+target/%:
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
 tools/%: FORCE
@@ -175,13 +153,22 @@ clean: FORCE
 dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
-distclean: dirclean config-clean
+distclean: dirclean config-clean symlinkclean docclean
        rm -rf dl
 
 help:
        cat README
 
-.SILENT: clean dirclean distclean config-clean download world
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
+symlinkclean:
+       find package -type l | xargs rm -f
+
+.SILENT: clean dirclean distclean symlinkclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help
 %: ;