nuke some unnecessary complexity in the metadata scanning - simply call include/scan...
[openwrt.git] / Makefile
index 40b4efc..bcbfd56 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -24,73 +14,161 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+
+all: world
+
+SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
+export TOPDIR=${CURDIR}
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
-all: world
-
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
+  world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+tmp/.pkginfo: FORCE
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="pkginfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(shell ls include/package*.mk) include/kernel.mk" SCAN_EXTRA=""
+
+tmp/.targetinfo: FORCE
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="$(shell ls include/kernel*.mk)" SCAN_EXTRA=""
+
+tmpinfo-clean: FORCE
+       @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+tmp/.config.in: tmp/.pkginfo
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+tmp/.config-target.in: tmp/.targetinfo
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+.config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
 
-config: scripts/config/conf
+scripts/config/mconf:
+       @$(MAKE) -C scripts/config all
+
+scripts/config/conf:
+       @$(MAKE) -C scripts/config conf
+
+config: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-defdconfig: scripts/config/conf
-       $< -d Config.in
+config-clean: FORCE
+       $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
+       touch .config
+       $< -D .config Config.in
 
-oldconfig: scripts/config/conf
+oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
        $< -o Config.in
 
-menuconfig: scripts/config/mconf
+menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+kernel_menuconfig: .config FORCE
+       -$(MAKE) target/linux-prepare
+       $(NO_TRACE_MAKE) -C target/linux menuconfig
 
-package/%: .pkginfo
+package/%: 
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: .pkginfo
+target/%:
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
-toolchain/%:
+tools/%: FORCE
+       $(MAKE) -C tools $(patsubst tools/%,%,$@)
+
+toolchain/%: tmp/.targetinfo FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world:
+tmp/.prereq-build: include/prereq-build.mk
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+tmp/.prereq-packages: include/prereq.mk tmp/.pkginfo .config
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+tmp/.prereq-target: include/prereq.mk tmp/.targetinfo .config
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: tmp/.prereq-build tmp/.prereq-packages tmp/.prereq-target FORCE
+
+download: .config FORCE
+       $(MAKE) tools/download
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
+       $(MAKE) tools/install
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
+       $(MAKE) package/index
+
+clean: FORCE
+       rm -rf build_* bin tmp
+
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
+
+distclean: dirclean config-clean symlinkclean docclean
+       rm -rf dl
+
+help:
+       cat README
+
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
+symlinkclean:
+       find package -type l | xargs rm -f
 
-.PHONY: FORCE
-FORCE:
+.SILENT: clean dirclean distclean symlinkclean config-clean download world
+FORCE: ;
+.PHONY: FORCE help
+%: ;