move "make symlinks" to "make package/symlinks"
[openwrt.git] / Makefile
index e97423e..35fc2c8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -52,33 +52,40 @@ ifeq ($(FORCE),)
   world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-tmp/.pkginfo:
+ifeq ($(IS_TTY),1)
+  define progress
+       printf "\033[M\r$(1)" >&2;
+  endef
+endif
+
+define dumpinfo
        @mkdir -p tmp
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
+       @echo -n Collecting $(2) info... 
+       @-for dir in $(1)/*/; do \
                [ -f "$${dir}/Makefile" ] || continue; \
+               $(call progress,Collecting $(2) info: $${dir%%/}) \
                echo Source-Makefile: $${dir}Makefile; \
                $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
                echo; \
        done > $@
+       @($(call progress,Collecting $(2) info: done))
+       @echo
+endef
+
+tmp/.pkginfo:
+       $(call dumpinfo,package,package)
 
 tmp/.targetinfo:
-       @mkdir -p tmp
-       @echo Collecting target info...
-       @-for dir in target/linux/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               ( cd "$$dir"; $(NO_TRACE_MAKE) --no-print-dir DUMP=1 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2 ); \
-               echo; \
-       done > $@
+       $(call dumpinfo,target/linux,target)
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -171,7 +178,16 @@ dirclean: clean
 distclean: dirclean config-clean
        rm -rf dl
 
+help:
+       cat README
+
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
-.PHONY: FORCE
+.PHONY: FORCE help
 %: ;