move "make symlinks" to "make package/symlinks"
[openwrt.git] / Makefile
index daadbea..35fc2c8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -82,10 +82,10 @@ tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -181,8 +181,11 @@ distclean: dirclean config-clean
 help:
        cat README
 
-symlinks:
-       scripts/feeds.sh https://svn.openwrt.org/openwrt/packages
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;