kernel: implement RENAME_EXCHANGE support for jffs2 - overlayfs requires it
[openwrt.git] / Makefile
index f75fc7f..2b08d30 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,6 @@ empty:=
 space:= $(empty) $(empty)
 $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
 
-.ONESHELL:
 world:
 
 include $(TOPDIR)/include/host.mk
@@ -76,10 +75,10 @@ endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
-       @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
-               echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+       @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
+               echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
                echo '       The missing file will cause configure scripts to fail during compilation.'; \
-               echo '       Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+               echo '       Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
                exit 1; \
        fi