fix invalid fd warning on mac os x
[openwrt.git] / Makefile
index ed1e34d..26721a3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,7 @@ RELEASE:=Kamikaze
 
 all: world
 
+SHELL:=/usr/bin/env bash
 export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
 
@@ -44,7 +45,7 @@ endif
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
 
 pkginfo-clean: FORCE