Revert "iptables: update to 1.4.18" due to toolchain-issue:
[openwrt.git] / package / network / utils / iptables / patches / 030-no-libnfnetlink.patch
1 --- a/configure
2 +++ b/configure
3 @@ -10917,75 +10917,7 @@ $as_echo "no" >&6; }
4         fi
5  fi
6  
7 -pkg_failed=no
8 -{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
9 -$as_echo_n "checking for libnfnetlink... " >&6; }
10 -
11 -if test -n "$libnfnetlink_CFLAGS"; then
12 -    pkg_cv_libnfnetlink_CFLAGS="$libnfnetlink_CFLAGS"
13 - elif test -n "$PKG_CONFIG"; then
14 -    if test -n "$PKG_CONFIG" && \
15 -    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
16 -  ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
17 -  ac_status=$?
18 -  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
19 -  test $ac_status = 0; }; then
20 -  pkg_cv_libnfnetlink_CFLAGS=`$PKG_CONFIG --cflags "libnfnetlink >= 1.0" 2>/dev/null`
21 -else
22 -  pkg_failed=yes
23 -fi
24 - else
25 -    pkg_failed=untried
26 -fi
27 -if test -n "$libnfnetlink_LIBS"; then
28 -    pkg_cv_libnfnetlink_LIBS="$libnfnetlink_LIBS"
29 - elif test -n "$PKG_CONFIG"; then
30 -    if test -n "$PKG_CONFIG" && \
31 -    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
32 -  ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
33 -  ac_status=$?
34 -  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
35 -  test $ac_status = 0; }; then
36 -  pkg_cv_libnfnetlink_LIBS=`$PKG_CONFIG --libs "libnfnetlink >= 1.0" 2>/dev/null`
37 -else
38 -  pkg_failed=yes
39 -fi
40 - else
41 -    pkg_failed=untried
42 -fi
43 -
44 -
45 -
46 -if test $pkg_failed = yes; then
47 -       { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
48 -$as_echo "no" >&6; }
49 -
50 -if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
51 -        _pkg_short_errors_supported=yes
52 -else
53 -        _pkg_short_errors_supported=no
54 -fi
55 -        if test $_pkg_short_errors_supported = yes; then
56 -               libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnfnetlink >= 1.0" 2>&1`
57 -        else
58 -               libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnfnetlink >= 1.0" 2>&1`
59 -        fi
60 -       # Put the nasty error message in config.log where it belongs
61 -       echo "$libnfnetlink_PKG_ERRORS" >&5
62 -
63 -       nfnetlink=0
64 -elif test $pkg_failed = untried; then
65 -       { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
66 -$as_echo "no" >&6; }
67 -       nfnetlink=0
68 -else
69 -       libnfnetlink_CFLAGS=$pkg_cv_libnfnetlink_CFLAGS
70 -       libnfnetlink_LIBS=$pkg_cv_libnfnetlink_LIBS
71 -        { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
72 -$as_echo "yes" >&6; }
73 -       nfnetlink=1
74 -fi
75 - if test "$nfnetlink" = 1; then
76 +if false; then
77    HAVE_LIBNFNETLINK_TRUE=
78    HAVE_LIBNFNETLINK_FALSE='#'
79  else
80 --- a/configure.ac
81 +++ b/configure.ac
82 @@ -79,9 +79,7 @@ AM_CONDITIONAL([ENABLE_LARGEFILE], [test
83  AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
84  AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
85  
86 -PKG_CHECK_MODULES([libnfnetlink], [libnfnetlink >= 1.0],
87 -       [nfnetlink=1], [nfnetlink=0])
88 -AM_CONDITIONAL([HAVE_LIBNFNETLINK], [test "$nfnetlink" = 1])
89 +AM_CONDITIONAL([HAVE_LIBNFNETLINK], [false])
90  
91  regular_CFLAGS="${largefile_cflags} \
92         -D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \