brcm63xx: fix livebox image generation
authorJonas Gorski <jogo@openwrt.org>
Tue, 2 Jun 2015 10:23:45 +0000 (10:23 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 2 Jun 2015 10:23:45 +0000 (10:23 +0000)
Livebox does need the uncompressed kernel, so just create it during
image generation.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45875 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile

index cb9bf27..a4889c2 100755 (executable)
@@ -94,6 +94,7 @@ endef
 
 define Image/Build/RedBootDTB
        # Prepare kernel and rootfs
+       cat $(KDIR)/vmlinux $(DTS_DIR)/$(3).dtb > $(KDIR)/vmlinux-$(3)
        gzip -9 -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
        dd if=$(KDIR)/vmlinux-$(3).bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-vmlinux.gz bs=65536 conv=sync
        dd if=$(KDIR)/root.squashfs of="$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs" bs=64k conv=sync
@@ -121,6 +122,7 @@ define Image/Build/RedBootDTB
                "$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs" \
                > "$(BIN_DIR)/$(IMG_PREFIX)-$(2)-redboot.bin"
        rm -f $(BIN_DIR)/redbootscript $(BIN_DIR)/redbootscript.padded
+       rm -f $(KDIR)/vmlinux-$(3)
 endef
 
 define Image/Build/HCSDTB