CC: version.mk and image-config.in: adjust to 15.05.1
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Mar 2016 14:45:02 +0000 (14:45 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Mar 2016 14:45:02 +0000 (14:45 +0000)
* Adjust the default version number in include/version.mk to 15.05.1
* Copy the correct download repo location from include/version.mk
  to base-files/image-config.in

After the change to version.mk, new builds made from CC sources will
have opkg config that downloads from the recent 15.05.1 packages repo
instead of the ancient 15.05 packages repo.

The change to image-config.in ensures that if somebody uses
VERSIONOPT config options in .config, he will get the
correct download repo address (instead of trunk snapshots).

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49053 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/version.mk
package/base-files/image-config.in

index 9348a24..ddce935 100644 (file)
@@ -21,7 +21,7 @@ qstrip_escape=$(subst ','\'',$(call qstrip,$(1)))
 #'
 
 VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),15.05)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),15.05.1)
 
 VERSION_CODE:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),Chaos Calmer)
index 495300d..0dfd6f6 100644 (file)
@@ -170,7 +170,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.openwrt.org/snapshots/trunk/%S/packages"
+               default "http://downloads.openwrt.org/%n/%v/%S/packages"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders: