CC: kernel: crypto: fix module loading of aead.ko
authorHauke Mehrtens <hauke@openwrt.org>
Sun, 9 Aug 2015 17:19:00 +0000 (17:19 +0000)
committerHauke Mehrtens <hauke@openwrt.org>
Sun, 9 Aug 2015 17:19:00 +0000 (17:19 +0000)
The name of the module was wrong before.

This should fix #20283.

backport of r46574.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46577 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index 22c790d..c8e0fbb 100644 (file)
@@ -41,7 +41,7 @@ define KernelPackage/crypto-aead
        CONFIG_CRYPTO_AEAD \
        CONFIG_CRYPTO_AEAD2
   FILES:=$(LINUX_DIR)/crypto/aead.ko
-  AUTOLOAD:=$(call AutoLoad,09,crypto_aead,1)
+  AUTOLOAD:=$(call AutoLoad,09,aead,1)
   $(call AddDepends/crypto)
 endef