uhttpd: update to the latest version, adds support for redirect helper scripts
authorFelix Fietkau <nbd@openwrt.org>
Wed, 18 Nov 2015 12:39:06 +0000 (12:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 18 Nov 2015 12:39:06 +0000 (12:39 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r47419

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47499 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/uhttpd.init

index d14e3a9..f757696 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_VERSION:=2015-10-20
+PKG_VERSION:=2015-11-08
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=618315bc0729c3064e06af2900a86211354f81c9
+PKG_SOURCE_VERSION:=fe01ef3f52adae9da38ef47926cd50974af5d6b7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 PKG_LICENSE:=ISC
@@ -33,7 +33,7 @@ endef
 
 define Package/uhttpd
   $(Package/uhttpd/default)
-  DEPENDS:=+libubox
+  DEPENDS:=+libubox +libblobmsg-json +libjson-script
 endef
 
 define Package/uhttpd/description
index 9bde7e5..f4c4968 100755 (executable)
@@ -136,6 +136,10 @@ start_instance()
                append_bool "$cfg" redirect_https "-q" 0
        }
 
+       for file in /etc/uhttpd/*.json; do
+               [ -s "$file" ] && procd_append_param command -H "$file"
+       done
+
        procd_close_instance
 }