bcm53xx: add fixtrx
authorHauke Mehrtens <hauke@openwrt.org>
Sun, 21 Sep 2014 21:56:31 +0000 (21:56 +0000)
committerHauke Mehrtens <hauke@openwrt.org>
Sun, 21 Sep 2014 21:56:31 +0000 (21:56 +0000)
Without running fixtrx the image will not boot at the second time,
because the CRC the boot loader check is invalid at that time.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42639 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/mtd/src/Makefile
target/linux/bcm53xx/base-files/etc/uci-defaults/09_fix_crc [new file with mode: 0644]

index 6450646..27ac339 100644 (file)
@@ -7,6 +7,7 @@ obj.seama = seama.o md5.o
 obj.ar71xx = trx.o $(obj.seama)
 obj.brcm = trx.o
 obj.brcm47xx = $(obj.brcm)
+obj.bcm53xx = $(obj.brcm)
 obj.brcm63xx = imagetag.o
 obj.ramips = $(obj.seama)
 
diff --git a/target/linux/bcm53xx/base-files/etc/uci-defaults/09_fix_crc b/target/linux/bcm53xx/base-files/etc/uci-defaults/09_fix_crc
new file mode 100644 (file)
index 0000000..346a532
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+#
+
+mtd fixtrx firmware