generic: upgrade to 3.14.34
authorJonas Gorski <jogo@openwrt.org>
Tue, 3 Mar 2015 14:39:52 +0000 (14:39 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 3 Mar 2015 14:39:52 +0000 (14:39 +0000)
Fixes several issues in the network stack.

Full changelog:
* https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.14.33
* https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.14.34

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44594 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-3.14/074-bgmac-register-napi-before-the-device.patch
target/linux/generic/patches-3.14/075-bgmac-activate-irqs-only-if-there-is-nothing-to-poll.patch
target/linux/generic/patches-3.14/130-mips_cpu_irq_disable.patch [deleted file]
target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.14/770-bgmac-fix-device-initialization-on-Northstar-SoCs-co.patch

index da88a5f..f8ae94d 100644 (file)
@@ -5,7 +5,7 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
-LINUX_VERSION-3.14 = .32
+LINUX_VERSION-3.14 = .34
 LINUX_VERSION-3.18 = .8
 LINUX_VERSION-3.19 = 
 LINUX_VERSION-4.0 = -rc1
@@ -13,7 +13,7 @@ LINUX_VERSION-4.0 = -rc1
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
-LINUX_KERNEL_MD5SUM-3.14.32 = 3178fb8f6f1eafcffdd730fec68754f8
+LINUX_KERNEL_MD5SUM-3.14.34 = 4061154fb66b24a8a1982a8adbe94335
 LINUX_KERNEL_MD5SUM-3.18.8  = 94673d5f4521a6077eb6fe0ab2633b35
 LINUX_KERNEL_MD5SUM-3.19    = d3fc8316d4d4d04b65cbc2d70799e763
 LINUX_KERNEL_MD5SUM-4.0-rc1 = 547b340dca94d358b68d2658822080fa
index 2eba9ee..aa45860 100644 (file)
@@ -11,11 +11,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  drivers/net/ethernet/broadcom/bgmac.c | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)
 
-diff --git a/drivers/net/ethernet/broadcom/bgmac.c b/drivers/net/ethernet/broadcom/bgmac.c
-index 05c6af6..aa9f950 100644
 --- a/drivers/net/ethernet/broadcom/bgmac.c
 +++ b/drivers/net/ethernet/broadcom/bgmac.c
-@@ -1515,6 +1515,8 @@ static int bgmac_probe(struct bcma_device *core)
+@@ -1515,6 +1515,8 @@ static int bgmac_probe(struct bcma_devic
        if (core->bus->sprom.boardflags_lo & BGMAC_BFL_ENETADM)
                bgmac_warn(bgmac, "Support for ADMtek ethernet switch not implemented\n");
  
@@ -24,7 +22,7 @@ index 05c6af6..aa9f950 100644
        err = bgmac_mii_register(bgmac);
        if (err) {
                bgmac_err(bgmac, "Cannot register MDIO\n");
-@@ -1529,8 +1531,6 @@ static int bgmac_probe(struct bcma_device *core)
+@@ -1529,8 +1531,6 @@ static int bgmac_probe(struct bcma_devic
  
        netif_carrier_off(net_dev);
  
@@ -33,7 +31,7 @@ index 05c6af6..aa9f950 100644
        return 0;
  
  err_mii_unregister:
-@@ -1549,9 +1549,9 @@ static void bgmac_remove(struct bcma_device *core)
+@@ -1549,9 +1549,9 @@ static void bgmac_remove(struct bcma_dev
  {
        struct bgmac *bgmac = bcma_get_drvdata(core);
  
@@ -44,6 +42,3 @@ index 05c6af6..aa9f950 100644
        bgmac_dma_free(bgmac);
        bcma_set_drvdata(core, NULL);
        free_netdev(bgmac->net_dev);
--- 
-1.8.4.5
-
index 506d8c6..cc43d36 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  drivers/net/ethernet/broadcom/bgmac.c | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)
 
-diff --git a/drivers/net/ethernet/broadcom/bgmac.c b/drivers/net/ethernet/broadcom/bgmac.c
-index aa9f950..3007d95 100644
 --- a/drivers/net/ethernet/broadcom/bgmac.c
 +++ b/drivers/net/ethernet/broadcom/bgmac.c
-@@ -1167,10 +1167,10 @@ static int bgmac_poll(struct napi_struct *napi, int weight)
+@@ -1167,10 +1167,10 @@ static int bgmac_poll(struct napi_struct
                bgmac->int_status = 0;
        }
  
@@ -30,6 +28,3 @@ index aa9f950..3007d95 100644
  
        return handled;
  }
--- 
-1.8.4.5
-
diff --git a/target/linux/generic/patches-3.14/130-mips_cpu_irq_disable.patch b/target/linux/generic/patches-3.14/130-mips_cpu_irq_disable.patch
deleted file mode 100644 (file)
index 7ebbc99..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/arch/mips/kernel/irq_cpu.c
-+++ b/arch/mips/kernel/irq_cpu.c
-@@ -56,6 +56,8 @@ static struct irq_chip mips_cpu_irq_cont
-       .irq_mask_ack   = mask_mips_irq,
-       .irq_unmask     = unmask_mips_irq,
-       .irq_eoi        = unmask_mips_irq,
-+      .irq_disable    = mask_mips_irq,
-+      .irq_enable     = unmask_mips_irq,
- };
- /*
-@@ -92,6 +94,8 @@ static struct irq_chip mips_mt_cpu_irq_c
-       .irq_mask_ack   = mips_mt_cpu_irq_ack,
-       .irq_unmask     = unmask_mips_irq,
-       .irq_eoi        = unmask_mips_irq,
-+      .irq_disable    = mask_mips_irq,
-+      .irq_enable     = unmask_mips_irq,
- };
- void __init mips_cpu_irq_init(void)
index 6daebe2..b94aaf8 100644 (file)
@@ -143,7 +143,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static const struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
-@@ -1595,6 +1612,11 @@ int ip6_route_add(struct fib6_config *cf
+@@ -1592,6 +1609,11 @@ int ip6_route_add(struct fib6_config *cf
                        rt->dst.output = ip6_pkt_prohibit_out;
                        rt->dst.input = ip6_pkt_prohibit;
                        break;
@@ -155,7 +155,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case RTN_THROW:
                default:
                        rt->dst.error = (cfg->fc_type == RTN_THROW) ? -EAGAIN
-@@ -2174,6 +2196,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2171,6 +2193,17 @@ static int ip6_pkt_prohibit_out(struct s
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
@@ -173,7 +173,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  /*
   *    Allocate a dst for local (unicast / anycast) address.
   */
-@@ -2376,7 +2409,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2373,7 +2406,8 @@ static int rtm_to_fib6_config(struct sk_
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
@@ -183,7 +183,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -2578,6 +2612,9 @@ static int rt6_fill_node(struct net *net
+@@ -2575,6 +2609,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
@@ -193,7 +193,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
-@@ -2828,6 +2865,8 @@ static int ip6_route_dev_notify(struct n
+@@ -2825,6 +2862,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3044,6 +3083,17 @@ static int __net_init ip6_route_net_init
+@@ -3041,6 +3080,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -220,7 +220,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -3062,6 +3112,8 @@ out:
+@@ -3059,6 +3109,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -229,7 +229,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3079,6 +3131,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3076,6 +3128,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -237,7 +237,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3175,6 +3228,9 @@ int __init ip6_route_init(void)
+@@ -3172,6 +3225,9 @@ int __init ip6_route_init(void)
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 0043b4c..1d6b66c 100644 (file)
@@ -18,11 +18,9 @@ Can we have it for 3.20, please?
  drivers/net/ethernet/broadcom/bgmac.c | 5 +++--
  1 file changed, 3 insertions(+), 2 deletions(-)
 
-diff --git a/drivers/net/ethernet/broadcom/bgmac.c b/drivers/net/ethernet/broadcom/bgmac.c
-index 3007d95..728373b 100644
 --- a/drivers/net/ethernet/broadcom/bgmac.c
 +++ b/drivers/net/ethernet/broadcom/bgmac.c
-@@ -1412,6 +1412,7 @@ static void bgmac_mii_unregister(struct bgmac *bgmac)
+@@ -1412,6 +1412,7 @@ static void bgmac_mii_unregister(struct
  /* http://bcm-v4.sipsolutions.net/mac-gbit/gmac/chipattach */
  static int bgmac_probe(struct bcma_device *core)
  {
@@ -30,7 +28,7 @@ index 3007d95..728373b 100644
        struct net_device *net_dev;
        struct bgmac *bgmac;
        struct ssb_sprom *sprom = &core->bus->sprom;
-@@ -1474,8 +1475,8 @@ static int bgmac_probe(struct bcma_device *core)
+@@ -1474,8 +1475,8 @@ static int bgmac_probe(struct bcma_devic
        bgmac_chip_reset(bgmac);
  
        /* For Northstar, we have to take all GMAC core out of reset */
@@ -41,6 +39,3 @@ index 3007d95..728373b 100644
                struct bcma_device *ns_core;
                int ns_gmac;
  
--- 
-1.8.4.5
-