build: use host cflags/ldflags for openssl prereq check
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2015 14:12:42 +0000 (14:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2015 14:12:42 +0000 (14:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r47138

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47140 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index 211201a..32c4ada 100644 (file)
@@ -68,7 +68,7 @@ $(eval $(call TestHostCommand,zlib, \
 $(eval $(call TestHostCommand,libssl, \
        Please install the openssl library (with development headers), \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
-               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+               gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
 
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \