mkimage: cross compile fix: pass HOST_*FLAGS in to uboot's makefile
authorFelix Fietkau <nbd@openwrt.org>
Thu, 26 Nov 2015 10:39:41 +0000 (10:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 26 Nov 2015 10:39:41 +0000 (10:39 +0000)
The HOST_*FLAGS are for compiling programs which will run on the machine that is
running the build.  Setting these flags is frequently required for unusual
cross-compiles.

Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>
Backport of r46424

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47651 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/mkimage/Makefile

index a65eedf..f73cc56 100644 (file)
@@ -31,8 +31,8 @@ define Host/Prepare
 endef
 
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) defconfig
-       $(MAKE) -C $(HOST_BUILD_DIR) tools-only
+       $(MAKE) -C $(HOST_BUILD_DIR) defconfig   HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
+       $(MAKE) -C $(HOST_BUILD_DIR) tools-only  HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
 endef
 
 define Host/Install