CC: kernel: update 3.18 to 3.18.20
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 19:01:16 +0000 (19:01 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 19:01:16 +0000 (19:01 +0000)
Changelog:
 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.20

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46680 3c298f89-4303-0410-b956-a3cf2f4a3e73

12 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
target/linux/ar71xx/patches-3.18/736-MIPS-ath79-add-MC-MAC1200R-support.patch
target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
target/linux/ar71xx/patches-3.18/738-MIPS-ath79-add-meraki-mr12-mr16-support.patch
target/linux/ar71xx/patches-3.18/800-MIPS-ath79-add-RB922GS-support.patch
target/linux/ar71xx/patches-3.18/903-MIPS-ath79-ubnt-rocket-m-xw-support.patch
target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch
target/linux/generic/patches-3.18/834-ledtrig-libata.patch
target/linux/oxnas/patches-3.18/999-libata-hacks.patch

index 1944597..243be33 100644 (file)
@@ -2,9 +2,9 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .19
+LINUX_VERSION-3.18 = .20
 
 
-LINUX_KERNEL_MD5SUM-3.18.19 = a143f9421bd8413752609d0d771c2955
+LINUX_KERNEL_MD5SUM-3.18.20 = 952c9159acdf4efbc96e08a27109d994
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index f11b2d0..941cb49 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-3.18.19/arch/mips/ath79/machtypes.h
-===================================================================
---- linux-3.18.19.orig/arch/mips/ath79/machtypes.h
-+++ linux-3.18.19/arch/mips/ath79/machtypes.h
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
 @@ -16,22 +16,195 @@
  
  enum ath79_mach_type {
 @@ -16,22 +16,195 @@
  
  enum ath79_mach_type {
@@ -198,10 +196,8 @@ Index: linux-3.18.19/arch/mips/ath79/machtypes.h
  };
  
  #endif /* _ATH79_MACHTYPE_H */
  };
  
  #endif /* _ATH79_MACHTYPE_H */
-Index: linux-3.18.19/arch/mips/ath79/Kconfig
-===================================================================
---- linux-3.18.19.orig/arch/mips/ath79/Kconfig
-+++ linux-3.18.19/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
 @@ -2,6 +2,70 @@ if ATH79
  
  menu "Atheros AR71XX/AR724X/AR913X machine selection"
 @@ -2,6 +2,70 @@ if ATH79
  
  menu "Atheros AR71XX/AR724X/AR913X machine selection"
@@ -1454,10 +1450,8 @@ Index: linux-3.18.19/arch/mips/ath79/Kconfig
        def_bool n
  
  endif
        def_bool n
  
  endif
-Index: linux-3.18.19/arch/mips/ath79/Makefile
-===================================================================
---- linux-3.18.19.orig/arch/mips/ath79/Makefile
-+++ linux-3.18.19/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
 @@ -38,9 +38,124 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
  #
  # Machines
 @@ -38,9 +38,124 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
  #
  # Machines
@@ -1583,10 +1577,8 @@ Index: linux-3.18.19/arch/mips/ath79/Makefile
 +obj-$(CONFIG_ATH79_MACH_ZCN_1523H)    += mach-zcn-1523h.o
 +obj-$(CONFIG_ATH79_MACH_CARAMBOLA2)   += mach-carambola2.o
 +obj-$(CONFIG_ATH79_MACH_NBG6716)      += mach-nbg6716.o
 +obj-$(CONFIG_ATH79_MACH_ZCN_1523H)    += mach-zcn-1523h.o
 +obj-$(CONFIG_ATH79_MACH_CARAMBOLA2)   += mach-carambola2.o
 +obj-$(CONFIG_ATH79_MACH_NBG6716)      += mach-nbg6716.o
-Index: linux-3.18.19/arch/mips/ath79/prom.c
-===================================================================
---- linux-3.18.19.orig/arch/mips/ath79/prom.c
-+++ linux-3.18.19/arch/mips/ath79/prom.c
+--- a/arch/mips/ath79/prom.c
++++ b/arch/mips/ath79/prom.c
 @@ -180,6 +180,12 @@ void __init prom_init(void)
                        ath79_prom_append_cmdline("board", env);
                }
 @@ -180,6 +180,12 @@ void __init prom_init(void)
                        ath79_prom_append_cmdline("board", env);
                }
index a24d496..b44e884 100644 (file)
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1218,6 +1218,10 @@ config SOC_AR934X
+@@ -1228,6 +1228,10 @@ config SOC_AR934X
        select PCI_AR724X if PCI
        def_bool n
  
        select PCI_AR724X if PCI
        def_bool n
  
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
-@@ -1260,7 +1264,7 @@ config ATH79_DEV_USB
+@@ -1270,7 +1274,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
        def_bool n
  
  config ATH79_DEV_WMAC
index 90c9b33..8f15790 100644 (file)
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1237,6 +1237,12 @@ config SOC_QCA955X
+@@ -1248,6 +1248,12 @@ config SOC_QCA955X
        select PCI_AR724X if PCI
        def_bool n
  
        select PCI_AR724X if PCI
        def_bool n
  
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
-@@ -1274,7 +1280,7 @@ config ATH79_DEV_USB
+@@ -1285,7 +1291,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
        def_bool n
  
  config ATH79_DEV_WMAC
index e22c26f..b9e1f7e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -578,6 +578,16 @@ config ATH79_MACH_R6100
+@@ -579,6 +579,16 @@ config ATH79_MACH_R6100
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -119,6 +119,7 @@ enum ath79_mach_type {
+@@ -120,6 +120,7 @@ enum ath79_mach_type {
        ATH79_MACH_TEW_673GRU,          /* TRENDnet TEW-673GRU */
        ATH79_MACH_TEW_712BR,           /* TRENDnet TEW-712BR */
        ATH79_MACH_TEW_732BR,           /* TRENDnet TEW-732BR */
        ATH79_MACH_TEW_673GRU,          /* TRENDnet TEW-673GRU */
        ATH79_MACH_TEW_712BR,           /* TRENDnet TEW-712BR */
        ATH79_MACH_TEW_732BR,           /* TRENDnet TEW-732BR */
index a8ee6f6..c77831f 100644 (file)
@@ -6,11 +6,11 @@
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
 +      ATH79_MACH_OM5P_AN,             /* OpenMesh OM5P-AN */
        ATH79_MACH_OM5P,                /* OpenMesh OM5P */
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
 +      ATH79_MACH_OM5P_AN,             /* OpenMesh OM5P-AN */
        ATH79_MACH_OM5P,                /* OpenMesh OM5P */
+       ATH79_MACH_ONION_OMEGA,         /* ONION OMEGA */
        ATH79_MACH_PB42,                /* Atheros PB42 */
        ATH79_MACH_PB42,                /* Atheros PB42 */
-       ATH79_MACH_PB92,                /* Atheros PB92 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -731,6 +731,7 @@ config ATH79_MACH_OM2P
+@@ -732,6 +732,7 @@ config ATH79_MACH_OM2P
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
index 22e9b94..4e65e0e 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -738,6 +738,26 @@ config ATH79_MACH_OM5P
-       select ATH79_DEV_M25P80
+@@ -749,6 +749,26 @@ config ATH79_MACH_ONION_OMEGA
+       select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
 +config ATH79_MACH_MR12
        select ATH79_DEV_WMAC
  
 +config ATH79_MACH_MR12
index a08a30f..7f1ac45 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -613,6 +613,16 @@ config ATH79_MACH_RB91X
+@@ -614,6 +614,16 @@ config ATH79_MACH_RB91X
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
@@ -19,7 +19,7 @@
         select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
         select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -101,6 +101,7 @@ obj-$(CONFIG_ATH79_MACH_R6100)             += mach-
+@@ -102,6 +102,7 @@ obj-$(CONFIG_ATH79_MACH_R6100)             += mach-
  obj-$(CONFIG_ATH79_MACH_RB4XX)                += mach-rb4xx.o
  obj-$(CONFIG_ATH79_MACH_RB750)                += mach-rb750.o
  obj-$(CONFIG_ATH79_MACH_RB91X)                += mach-rb91x.o
  obj-$(CONFIG_ATH79_MACH_RB4XX)                += mach-rb4xx.o
  obj-$(CONFIG_ATH79_MACH_RB750)                += mach-rb750.o
  obj-$(CONFIG_ATH79_MACH_RB91X)                += mach-rb91x.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_RBSXTLITE)    += mach-rbsxtlite.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
  obj-$(CONFIG_ATH79_MACH_RBSXTLITE)    += mach-rbsxtlite.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -108,6 +108,7 @@ enum ath79_mach_type {
+@@ -109,6 +109,7 @@ enum ath79_mach_type {
        ATH79_MACH_RB_750G_R3,          /* MikroTik RouterBOARD 750GL */
        ATH79_MACH_RB_751,              /* MikroTik RouterBOARD 751 */
        ATH79_MACH_RB_751G,             /* Mikrotik RouterBOARD 751G */
        ATH79_MACH_RB_750G_R3,          /* MikroTik RouterBOARD 750GL */
        ATH79_MACH_RB_751,              /* MikroTik RouterBOARD 751 */
        ATH79_MACH_RB_751G,             /* Mikrotik RouterBOARD 751G */
index 7fdefd6..a0fc34f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -174,6 +174,7 @@ enum ath79_mach_type {
+@@ -175,6 +175,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
index d49af48..f9ca7eb 100644 (file)
@@ -5,7 +5,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 ---
 --- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
 +++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
 ---
 --- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
 +++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-@@ -143,6 +143,12 @@
+@@ -123,6 +123,12 @@
                #address-cells = <1>;
                #size-cells = <0>;
  
                #address-cells = <1>;
                #size-cells = <0>;
  
index 7d234ea..1360ce9 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4756,6 +4769,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4761,6 +4774,9 @@ static struct ata_queued_cmd *ata_qc_new
                        break;
                }
        }
                        break;
                }
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        return qc;
  }
  
        return qc;
  }
-@@ -5666,6 +5682,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5671,6 +5687,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5687,6 +5706,12 @@ static void ata_host_release(struct devi
+@@ -5692,6 +5711,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6133,7 +6158,23 @@ int ata_host_register(struct ata_host *h
+@@ -6138,7 +6163,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -871,6 +874,12 @@ struct ata_port {
+@@ -872,6 +875,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index 702a336..b3ff7fa 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -4752,6 +4760,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4757,6 +4765,9 @@ static struct ata_queued_cmd *ata_qc_new
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        for (i = 0, tag = ap->last_tag + 1; i < max_queue; i++, tag++) {
                if (ap->flags & ATA_FLAG_LOWTAG)
                        tag = i;
        for (i = 0, tag = ap->last_tag + 1; i < max_queue; i++, tag++) {
                if (ap->flags & ATA_FLAG_LOWTAG)
                        tag = i;
-@@ -4824,6 +4835,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -4829,6 +4840,8 @@ void ata_qc_free(struct ata_queued_cmd *
        if (likely(ata_tag_valid(tag))) {
                qc->tag = ATA_TAG_POISON;
                clear_bit(tag, &ap->qc_allocated);
        if (likely(ata_tag_valid(tag))) {
                qc->tag = ATA_TAG_POISON;
                clear_bit(tag, &ap->qc_allocated);
@@ -36,7 +36,7 @@
  
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
  
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
-@@ -900,6 +900,8 @@ struct ata_port_operations {
+@@ -901,6 +901,8 @@ struct ata_port_operations {
        void (*qc_prep)(struct ata_queued_cmd *qc);
        unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
        bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
        void (*qc_prep)(struct ata_queued_cmd *qc);
        unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
        bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
@@ -45,7 +45,7 @@
  
        /*
         * Configuration and exception handling
  
        /*
         * Configuration and exception handling
-@@ -990,6 +992,9 @@ struct ata_port_operations {
+@@ -991,6 +993,9 @@ struct ata_port_operations {
        void (*phy_reset)(struct ata_port *ap);
        void (*eng_timeout)(struct ata_port *ap);
  
        void (*phy_reset)(struct ata_port *ap);
        void (*eng_timeout)(struct ata_port *ap);