opkg: fix duplicate check_signature line for smime variant (#19863)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Jun 2015 10:51:38 +0000 (10:51 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Jun 2015 10:51:38 +0000 (10:51 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r45999

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46000 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/opkg/Makefile

index d313c44..d38ed52 100644 (file)
@@ -112,9 +112,6 @@ define Package/opkg/Default/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/opkg$(2).conf $(1)/etc/opkg.conf
-  ifneq ($(CONFIG_SIGNED_PACKAGES),)
-       echo "option check_signature 1" >> $(1)/etc/opkg.conf
-  endif
        $(call FeedSourcesAppend,$(1)/etc/opkg.conf)
        $(VERSION_SED) $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
        $(call FeedSourcesAppend,$(1)/etc/opkg.conf)
        $(VERSION_SED) $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
@@ -122,6 +119,9 @@ endef
 
 define Package/opkg/install
        $(call Package/opkg/Default/install,$(1),)
 
 define Package/opkg/install
        $(call Package/opkg/Default/install,$(1),)
+  ifneq ($(CONFIG_SIGNED_PACKAGES),)
+       echo "option check_signature 1" >> $(1)/etc/opkg.conf
+  endif
        mkdir $(1)/usr/sbin
        $(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/
 endef
        mkdir $(1)/usr/sbin
        $(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/
 endef