brcm63xx: kmod-bcm63xx-udc: fix module path for 3.18+
authorJonas Gorski <jogo@openwrt.org>
Sun, 15 Mar 2015 14:19:10 +0000 (14:19 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 15 Mar 2015 14:19:10 +0000 (14:19 +0000)
Fix the module path for linux 3.18+.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44785 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/modules.mk

index 48a2bf8..635a992 100644 (file)
@@ -25,7 +25,9 @@ define KernelPackage/bcm63xx-udc
   TITLE:=Broadcom BCM63xx UDC support
   DEPENDS:=@TARGET_brcm63xx +kmod-usb-gadget
   KCONFIG:=CONFIG_USB_BCM63XX_UDC
-  FILES:=$(LINUX_DIR)/drivers/usb/gadget/bcm63xx_udc.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/usb/gadget/bcm63xx_udc.ko@lt3.18 \
+       $(LINUX_DIR)/drivers/usb/gadget/udc/bcm63xx_udc.ko@ge3.18
   AUTOLOAD:=$(call AutoLoad,51,bcm63xx_udc)
   $(call AddDepends/usb)
 endef