kernel: use bcma-hcd.ko on bcm53xx for ohci
authorrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Jun 2015 05:04:53 +0000 (05:04 +0000)
committerrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 16 Jun 2015 05:04:53 +0000 (05:04 +0000)
On bcm53xx we still need usb-ohci to support USB 1.1 devices and it
obviously needs bcma-hcd.ko that will init controller and register
platform device.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Backport of r45994

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@45996 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/usb.mk

index 68f22cc..f27fcbd 100644 (file)
@@ -300,6 +300,7 @@ $(eval $(call KernelPackage,usb-uhci,1))
 define KernelPackage/usb-ohci
   TITLE:=Support for OHCI controllers
   DEPENDS:= \
+       +TARGET_bcm53xx:kmod-usb-bcma \
        +TARGET_brcm47xx:kmod-usb-bcma \
        +TARGET_brcm47xx:kmod-usb-ssb
   KCONFIG:= \