CC: ar71xx: EPG5000 requires ATH79_NVRAM
[15.05/openwrt.git] / target / linux / ar71xx / patches-3.18 / 718-MIPS-ath79-add-EPG5000-support.patch
index 579e024..a86fb55 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -196,6 +196,16 @@ config ATH79_MACH_F9K1115V2
+@@ -196,6 +196,17 @@ config ATH79_MACH_F9K1115V2
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
 +      select ATH79_DEV_M25P80
 +      select ATH79_DEV_USB
 +      select ATH79_DEV_WMAC
++      select ATH79_NVRAM
 +
  config ATH79_MACH_ESR1750
        bool "EnGenius ESR1750 board support"
        select SOC_QCA955X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -69,6 +69,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2)    += mach-eap300v2.o
+@@ -71,6 +71,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2)    += mac
  obj-$(CONFIG_ATH79_MACH_EAP7660D)     += mach-eap7660d.o
  obj-$(CONFIG_ATH79_MACH_EL_M150)      += mach-el-m150.o
  obj-$(CONFIG_ATH79_MACH_EL_MINI)      += mach-el-mini.o
@@ -29,7 +30,7 @@
  obj-$(CONFIG_ATH79_MACH_GL_INET)      += mach-gl-inet.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -59,6 +59,7 @@ enum ath79_mach_type {
+@@ -61,6 +61,7 @@ enum ath79_mach_type {
        ATH79_MACH_EL_M150,             /* EasyLink EL-M150 */
        ATH79_MACH_EL_MINI,             /* EasyLink EL-MINI */
        ATH79_MACH_ESR1750,             /* EnGenius ESR1750 */