install headers and library
[project/ustream-ssl.git] / CMakeLists.txt
index bd8ce3f..640afce 100644 (file)
@@ -25,3 +25,11 @@ ADD_EXECUTABLE(ustream-example ustream-example.c)
 TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
 
 SET(CMAKE_INSTALL_PREFIX /usr)
+
+FILE(GLOB headers *.h)
+INSTALL(FILES ${headers}
+       DESTINATION include/libubox
+)
+INSTALL(TARGETS ustream-ssl
+       LIBRARY DESTINATION lib
+)