ustream-ssl: cyassl compatibility with build time options
[project/ustream-ssl.git] / CMakeLists.txt
index c1c2b32..2ce9bf8 100644 (file)
@@ -21,6 +21,7 @@ ELSEIF(CYASSL)
   IF (HAVE_CYASSL_VERSION_H)
     ADD_DEFINITIONS(-DHAVE_CYASSL_VERSION_H)
   ENDIF()
+  ADD_DEFINITIONS(-DHAVE_CYASSL)
   SET(SSL_SRC ustream-io-cyassl.c ustream-openssl.c)
   SET(SSL_LIB cyassl m)
 ELSE()