add polarssl support
[project/ustream-ssl.git] / CMakeLists.txt
index 6af1750..1178c62 100644 (file)
@@ -10,7 +10,11 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
-IF(CYASSL)
+IF(POLARSSL)
+  ADD_DEFINITIONS(-DHAVE_POLARSSL)
+  SET(SSL_SRC ustream-polarssl.c)
+  SET(SSL_LIB polarssl m)
+ELSEIF(CYASSL)
   SET(SSL_SRC ustream-io-cyassl.c ustream-openssl.c)
   SET(SSL_LIB cyassl m)
 ELSE()