contrib/uhttpd: add patch to fix linking on recent distros, refresh environment patch
[project/luci.git] / contrib / uhttpd / patches / 002-link-order.patch
diff --git a/contrib/uhttpd/patches/002-link-order.patch b/contrib/uhttpd/patches/002-link-order.patch
new file mode 100644 (file)
index 0000000..8bdd335
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,7 @@ endif
+       $(CC) $(CFLAGS) -c -o $@ $<
+ compile: $(OBJ) $(TLSLIB) $(LUALIB)
+-      $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
++      $(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
+ clean:
+       rm -f *.o *.so uhttpd