Rework LuCI build system
[project/luci.git] / collections / luci / Makefile
diff --git a/collections/luci/Makefile b/collections/luci/Makefile
new file mode 100644 (file)
index 0000000..dff5be6
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=luci
+
+LUCI_TITLE:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
+LUCI_DEPENDS:= \
+       +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
+       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +luci-lib-nixio
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature