luci-ssl-openssl: Provide OpenSSL-based LuCI collection
[project/luci.git] / collections / luci-ssl-openssl / Makefile
diff --git a/collections/luci-ssl-openssl/Makefile b/collections/luci-ssl-openssl/Makefile
new file mode 100644 (file)
index 0000000..37442a3
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2016 The LuCI Team
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl-openssl
+
+LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ Note: px5g still requires libpolarssl
+LUCI_DEPENDS:=+luci +libustream-openssl +px5g
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature