[packages] xtables-addons: enforce CONFIG_NF_CONNTRACK_MARK for kmod-compat-xtables
[packages.git] / net / xtables-addons / Makefile
index 4b39836..2d3017d 100644 (file)
@@ -91,6 +91,7 @@ define BuildTemplate
     SUBMENU:=Netfilter Extensions
     TITLE:=$(2) netfilter module
     DEPENDS:=kmod-ipt-core $(6)
+    KCONFIG:=$(7)
     FILES:=$(foreach mod,$(4),$(PKG_BUILD_DIR)/extensions/$(mod).$(LINUX_KMOD_SUFFIX))
     AUTOLOAD:=$(call AutoLoad,$(5),$(notdir $(4)))
   endef
@@ -102,7 +103,7 @@ endef
 
 #$(eval $(call BuildTemplate,SUFFIX,DESCRIPTION,EXTENSION,MODULE,PRIORITY,DEPENDS))
 
-$(eval $(call BuildTemplate,compat-xtables,API compatibilty layer,,compat_xtables,45,))
+$(eval $(call BuildTemplate,compat-xtables,API compatibilty layer,,compat_xtables,45,,CONFIG_NF_CONNTRACK_MARK=y))
 $(eval $(call BuildTemplate,rawpost,RAWPOST,,iptable_rawpost $(if $(CONFIG_IPV6),ip6table_rawpost),50,+kmod-ipt-compat-xtables))
 $(eval $(call BuildTemplate,nathelper-rtsp,RTSP Conntrack and NAT,,rtsp/nf_conntrack_rtsp rtsp/nf_nat_rtsp,46,+kmod-ipt-conntrack-extra))