[packages] php5: fix paths in php-config, used by pecl module builds
[packages.git] / lang / php5 / Makefile
index d086223..f7a728c 100644 (file)
@@ -471,6 +471,7 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR_HOST)
        sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
        sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
+       sed -i -e "s#prefix=\"/usr\"#prefix=\"$(STAGING_DIR_HOST)/usr\"#" $(STAGING_DIR_HOST)/usr/bin/php-config
 endef
 
 define BuildModule