Port privoxy to -ng
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Aug 2006 09:00:32 +0000 (09:00 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Aug 2006 09:00:32 +0000 (09:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4497 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/privoxy/Makefile [new file with mode: 0644]
net/privoxy/patches/100-crosscompile.patch [new file with mode: 0644]
net/privoxy/patches/101-destdir.patch [new file with mode: 0644]

diff --git a/net/privoxy/Makefile b/net/privoxy/Makefile
new file mode 100644 (file)
index 0000000..fea7209
--- /dev/null
@@ -0,0 +1,82 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=privoxy
+PKG_VERSION:=3.0.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
+
+PKG_SOURCE_URL:=@SF/ijbswa
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/privoxy
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=web proxy with advanced filtering capabilities
+  DESCRIPTION:=Privoxy is a web proxy with advanced filtering capabilities for\\\
+       protecting privacy, modifying web page content, managing cookies,\\\
+       controlling access, and removing ads, banners, pop-ups and other\\\
+       obnoxious Internet junk. Privoxy has a very flexible configuration\\\
+       and can be customized to suit individual needs and tastes. Privoxy\\\
+       has application for both stand-alone systems and multi-user networks.\\\
+  URL:=http://www.privoxy.org/
+endef
+
+define Build/Configure
+  (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+                autoheader && autoconf && \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(strip $(TARGET_CFLAGS))" \
+                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+                ./configure \
+                  --target=$(GNU_TARGET_NAME) \
+                  --host=$(GNU_TARGET_NAME) \
+                  --build=$(GNU_HOST_NAME) \
+                  --program-prefix="" \
+                  --program-suffix="" \
+                  --prefix=/usr \
+                  --exec-prefix=/usr \
+                  --bindir=/usr/bin \
+                  --datadir=/usr/share \
+                  --includedir=/usr/include \
+                  --infodir=/usr/share/info \
+                  --libdir=/usr/lib \
+                  --libexecdir=/usr/lib \
+                  --localstatedir=/var \
+                  --mandir=/usr/share/man \
+                  --sbindir=/usr/sbin \
+                  --sysconfdir=/etc \
+                  $(DISABLE_NLS) \
+                  --disable-static \
+        );
+endef
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               SPECIAL_CFLAGS="-pthread -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+endef
+
+define Package/privoxy/install 
+       install -d -m0755 $(1)/usr/sbin $(1)/etc/privoxy 
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,privoxy))
diff --git a/net/privoxy/patches/100-crosscompile.patch b/net/privoxy/patches/100-crosscompile.patch
new file mode 100644 (file)
index 0000000..c2b6738
--- /dev/null
@@ -0,0 +1,13 @@
+diff -Nur privoxy-3.0.3-stable/configure.in privoxy-3.0.3-stable.patched/configure.in
+--- privoxy-3.0.3-stable/configure.in  2004-01-30 10:26:03.000000000 +0100
++++ privoxy-3.0.3-stable.patched/configure.in  2006-03-13 20:50:57.000000000 +0100
+@@ -1092,7 +1092,8 @@
+ AC_PROG_GCC_TRADITIONAL
+ dnl uncommenting does not work for swa. suse linux
+ dnl AC_FUNC_MALLOC
+-AC_FUNC_SETPGRP
++dnl uncommenting does not work for openwrt
++dnl AC_FUNC_SETPGRP
+ AC_TYPE_SIGNAL
+ dnl uncommenting does not work for swa. suse linux
+ dnl AC_FUNC_STAT
diff --git a/net/privoxy/patches/101-destdir.patch b/net/privoxy/patches/101-destdir.patch
new file mode 100644 (file)
index 0000000..9e22ab6
--- /dev/null
@@ -0,0 +1,32 @@
+diff -Nur privoxy-3.0.3-stable/GNUmakefile.in privoxy-3.0.3-stable.patched/GNUmakefile.in
+--- privoxy-3.0.3-stable/GNUmakefile.in        2004-01-31 02:15:33.000000000 +0100
++++ privoxy-3.0.3-stable.patched/GNUmakefile.in        2006-03-13 21:39:29.000000000 +0100
+@@ -55,17 +55,17 @@
+ USER         = @USER@
+ GROUP    = @GROUP@
+-prefix       = @prefix@
+-exec_prefix  = @exec_prefix@
+-CONF_BASE    = @sysconfdir@
+-SBIN_DEST    = @sbindir@
+-MAN_DIR      = @mandir@
+-MAN_DEST     = $(MAN_DIR)/man1
+-SHARE_DEST   = @datadir@
+-DOC_DEST     = $(SHARE_DEST)/doc/privoxy
+-VAR_DEST     = @localstatedir@
+-LOGS_DEST    = $(VAR_DEST)/log/privoxy
+-PIDS_DEST    = $(VAR_DEST)/run
++prefix       = $(DESTDIR)@prefix@
++exec_prefix  = $(DESTDIR)@exec_prefix@
++CONF_BASE    = $(DESTDIR)@sysconfdir@
++SBIN_DEST    = $(DESTDIR)@sbindir@
++MAN_DIR      = $(DESTDIR)@mandir@
++MAN_DEST     = $(DESTDIR)$(MAN_DIR)/man1
++SHARE_DEST   = $(DESTDIR)@datadir@
++DOC_DEST     = $(DESTDIR)$(SHARE_DEST)/doc/privoxy
++VAR_DEST     = $(DESTDIR)@localstatedir@
++LOGS_DEST    = $(DESTDIR)$(VAR_DEST)/log/privoxy
++PIDS_DEST    = $(DESTDIR)$(VAR_DEST)/run
+ # if $prefix = /usr/local then the default CONFDEST change from 
+ # CONF_DEST = $(CONF_BASE) to CONF_DEST = $(CONF_BASE)/privoxy