Added package gconv-modules, which is glibc-specific and need by many packages...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jan 2010 03:27:53 +0000 (03:27 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jan 2010 03:27:53 +0000 (03:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19161 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gconv-modules/Makefile [new file with mode: 0644]

diff --git a/libs/gconv-modules/Makefile b/libs/gconv-modules/Makefile
new file mode 100644 (file)
index 0000000..15931e3
--- /dev/null
@@ -0,0 +1,45 @@
+# 
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gconv-modules
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gconv-modules
+  SECTION:=libs
+  CATEGORY:=Base system
+  DEPENDS:=@USE_GLIBC
+  DEFAULT:=y
+  TITLE:=The GNU libc charset conversion modules
+endef
+
+define Package/gconv-modules/description
+ This package contains helper modules necessary to convert data between
+various charsets.
+endef
+
+define Build/Compile
+endef
+
+define Package/gconv-modules/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(TOOLCHAIN_DIR)/usr/lib/gconv $(1)/usr/lib
+
+       rm -f $(1)/usr/lib/gconv/EUC-*.so
+       rm -f $(1)/usr/lib/gconv/ISO-2022-*.so
+       rm -f $(1)/usr/lib/gconv/JOHAB.so
+       rm -f $(1)/usr/lib/gconv/UHC.so
+
+#      $(INSTALL_DIR) $(1)/usr/bin
+#      $(INSTALL_BIN) $(TOOLCHAIN_DIR)/usr/bin/iconv $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,gconv-modules))