dbus: for some reason on our mips toolchain -Wl,--gc-sections does not work, but...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Nov 2009 10:22:29 +0000 (10:22 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Nov 2009 10:22:29 +0000 (10:22 +0000)
fixes #6043

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18308 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/dbus/Makefile

index 95f978c..cbf502e 100644 (file)
@@ -74,6 +74,11 @@ $(call Package/dbus/Default/description)
 endef
 
 
+define Build/Prepare
+       $(Build/Prepare/Default)
+       $(SED) 's/-Wl,--gc-sections/--gc-sections/' $(PKG_BUILD_DIR)/configure
+endef
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \