[package] comgt: add ACM hotplug
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Feb 2011 17:24:25 +0000 (17:24 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Feb 2011 17:24:25 +0000 (17:24 +0000)
This adds in support for ttyACM devices in the 3g hotplug script.

Signed-off-by: Matthew Eaton <wrt at divinehawk.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25621 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/comgt/Makefile
package/comgt/files/3g.usb

index 5e36ad7..c3cf8ed 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index c52646b..ecaa96f 100644 (file)
@@ -36,8 +36,8 @@ if [ "$ACTION" = add ]; then
        esac
 
        local tty
-       for tty in /sys/$DEVPATH/ttyUSB*; do
-               [ -d "$tty" ] || break
+       for tty in /sys/$DEVPATH/ttyUSB* /sys/$DEVPATH/tty/ttyACM*;; do
+               [ -d "$tty" ] || continue
                config_foreach find_3g_iface interface "$tty"
        done
 fi