port bluez-utils to buildroot-ng
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jul 2006 15:04:33 +0000 (15:04 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jul 2006 15:04:33 +0000 (15:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4311 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/bluez-utils/Makefile [new file with mode: 0644]
utils/bluez-utils/files/givepin [new file with mode: 0644]
utils/bluez-utils/patches/001-include_limits.patch [new file with mode: 0644]
utils/bluez-utils/patches/002-hcid_pin_helper.patch [new file with mode: 0644]

diff --git a/utils/bluez-utils/Makefile b/utils/bluez-utils/Makefile
new file mode 100644 (file)
index 0000000..2d4abe7
--- /dev/null
@@ -0,0 +1,106 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bluez-utils
+PKG_VERSION:=2.24
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
+PKG_MD5SUM:=
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bluez-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+bluez-libs +libpthread
+  TITLE:=Bluetooth utilities
+  DESCRIPTION:=Bluetooth utilities.
+  URL:=http://www.bluez.org/
+endef
+
+define Package/bluez-utils/conffiles
+/etc/bluetooth/givepin
+/etc/bluetooth/hcid.conf
+/etc/bluetooth/rfcomm.conf
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --disable-dbus \
+                       --disable-fuse \
+                       --disable-obex \
+                       --disable-alsa \
+                       --disable-cups \
+                       --disable-pcmcia \
+                       --disable-initscripts \
+                       --disable-bccmd \
+                       --disable-avctrl \
+                       --disable-hid2hci \
+                       --disable-dfutool \
+                       --disable-bcm203x \
+                       --disable-bluepin \
+                       --with-bluez=$(STAGING_DIR)/usr/include \
+                       --with-usb=$(STAGING_DIR)/usr/include \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/bluez-utils/install
+       install -d -m0755 $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       install -d -m0755 $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       install -d -m0755 $(1)/etc/bluetooth
+       $(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(1)/etc/bluetooth/
+       $(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(1)/etc/bluetooth/
+       install -m0700 ./files/givepin $(1)/etc/bluetooth/
+endef
+
+$(eval $(call BuildPackage,bluez-utils))
diff --git a/utils/bluez-utils/files/givepin b/utils/bluez-utils/files/givepin
new file mode 100644 (file)
index 0000000..e52a338
--- /dev/null
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+# Write bluetooth PIN number here:
+pin=
+
+if [ -z "$pin" ]; then
+       msg="Set bluetooth PIN in file $0"
+       logger -p user.err "$msg"
+       for i in /dev/pts/* ; do
+               [ -w $i ] && echo "$msg" > $i
+       done
+else
+       echo "PIN:$pin"
+fi
diff --git a/utils/bluez-utils/patches/001-include_limits.patch b/utils/bluez-utils/patches/001-include_limits.patch
new file mode 100644 (file)
index 0000000..6f6cb82
--- /dev/null
@@ -0,0 +1,22 @@
+diff -ur bluez-utils-2.17.orig/hidd/sdp.c bluez-utils-2.17/hidd/sdp.c
+--- bluez-utils-2.17.orig/hidd/sdp.c   2005-05-09 20:33:24.000000000 +0200
++++ bluez-utils-2.17/hidd/sdp.c        2005-07-26 14:38:13.000000000 +0200
+@@ -39,6 +39,7 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/socket.h>
++#include <linux/limits.h>
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/l2cap.h>
+diff -ur bluez-utils-2.17.orig/tools/hciconfig.c bluez-utils-2.17/tools/hciconfig.c
+--- bluez-utils-2.17.orig/tools/hciconfig.c    2005-05-09 20:33:24.000000000 +0200
++++ bluez-utils-2.17/tools/hciconfig.c 2005-07-26 14:34:29.000000000 +0200
+@@ -40,6 +40,7 @@
+ #include <getopt.h>
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
++#include <linux/limits.h>
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/hci.h>
diff --git a/utils/bluez-utils/patches/002-hcid_pin_helper.patch b/utils/bluez-utils/patches/002-hcid_pin_helper.patch
new file mode 100644 (file)
index 0000000..17a7f36
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ur bluez-utils-2.17.orig/hcid/hcid.conf bluez-utils-2.17/hcid/hcid.conf
+--- bluez-utils-2.17.orig/hcid/hcid.conf       2004-12-25 19:06:00.000000000 +0100
++++ bluez-utils-2.17/hcid/hcid.conf    2005-07-26 14:44:23.000000000 +0200
+@@ -23,7 +23,7 @@
+       pairing multi;
+       # PIN helper
+-      pin_helper /usr/bin/bluepin;
++      pin_helper /etc/bluetooth/givepin;
+       # D-Bus PIN helper
+       #dbus_pin_helper;
+@@ -34,7 +34,7 @@
+       # Local device name
+       #   %d - device id
+       #   %h - host name
+-      name "BlueZ (%d)";
++      name "OpenWRT";
+       # Local device class
+       class 0x3e0100;