mc: prevent from picking up ncursesw
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Jul 2011 23:26:27 +0000 (23:26 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Jul 2011 23:26:27 +0000 (23:26 +0000)
mc will link against ncursesw instead of ncurses if it finds it. Make sure
it always links only against ncurses.

Closes #9225 and #9315.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27719 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/mc/Makefile

index 42b2e17..974f2da 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
 PKG_VERSION:=4.7.5.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
@@ -45,7 +45,8 @@ CONFIGURE_ARGS += \
        --without-edit \
        --without-gpm-mouse \
        --without-subshell \
-       --without-x
+       --without-x \
+       ac_cv_search_addwstr=no
 
 AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))