because of limitations in hostpython, numpy has to depend on python 2.5 development...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2008 23:35:30 +0000 (23:35 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Aug 2008 23:35:30 +0000 (23:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12186 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/numpy/Makefile

index 4179f0a..217c975 100644 (file)
@@ -30,7 +30,7 @@ define Package/numpy/description
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) $(STAGING_DIR)/host/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
+       cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) python2.5 ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr"
        sed -i "s/UCS4/UCS2/g" $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/numpy/core/multiarray.so
 endef
 
@@ -40,3 +40,11 @@ define Package/numpy/install
 endef
 
 $(eval $(call BuildPackage,numpy))
+
+define Require/python25-dev
+[ -e /usr/include/python2.5/pyconfig.h ]
+endef
+
+$(eval $(call Require,python25-dev, \
+       Please install Python 2.5 (including development headers and libraries) \
+))