packages/vips: explicitly enable exif, jpeg & png support and disable everything...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:15:41 +0000 (22:15 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:15:41 +0000 (22:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29057 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/vips/Makefile

index d4e2f1a..2fa68d4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vips
 PKG_VERSION:=7.26.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.vips.ecs.soton.ac.uk/supported/7.26/
@@ -21,20 +21,13 @@ include $(INCLUDE_DIR)/nls.mk
 
 PKG_INSTALL=1
 
-define Package/vips/Default
-  TITLE:=vips
-  URL:=http://www.vips.ecs.soton.ac.uk/
-endef
-
 define Package/vips
   $(call Package/vips/Default)
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg +glib2 +libxml2 $(INTL_DEPENDS)
-endef
-
-define Package/vips/description
-  An image manipulation library.
+  TITLE:=An image manipulation library
+  URL:=http://www.vips.ecs.soton.ac.uk/
+  DEPENDS:=+glib2 +libexif +libjpeg +libpng +libxml2 $(INTL_DEPENDS)
 endef
 
 TARGET_LDFLAGS+= \
@@ -43,8 +36,22 @@ TARGET_LDFLAGS+= \
 CONFIGURE_ARGS += \
        --disable-cxx \
        --disable-threads \
-       --without-liboil \
-       --without-magick
+       --without-cfitsio \
+       --without-fftw3 \
+       --without-lcms \
+       --without-magick \
+       --without-matio \
+       --without-OpenEXR \
+       --without-orc \
+       --without-pangoft2 \
+       --without-python \
+       --without-tiff \
+       --without-v4l \
+       --without-x \
+       --without-zip \
+       --with-jpeg \
+       --with-libexif \
+       --with-png \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/vips