add matchbox-window-manager
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Jan 2008 11:24:19 +0000 (11:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Jan 2008 11:24:19 +0000 (11:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10249 3c298f89-4303-0410-b956-a3cf2f4a3e73

XOrg/app/matchbox/Makefile [new file with mode: 0644]

diff --git a/XOrg/app/matchbox/Makefile b/XOrg/app/matchbox/Makefile
new file mode 100644 (file)
index 0000000..5cd7dca
--- /dev/null
@@ -0,0 +1,41 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=matchbox-window-manager
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://matchbox-project.org/sources/matchbox-window-manager/$(PKG_VERSION)
+
+PKG_FIXUP = libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/matchbox
+  TITLE:=matchbox window manager
+  SECTION:=xorg-wm
+  CATEGORY:=Xorg
+  DEPENDS:=+xorg-server-essentials +zlib +libfreetype +fontconfig @DISPLAY_SUPPORT
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               LIBMB_LIBS="-L$(STAGING_DIR)/usr/lib -lfontconfig -lXrender -lz -lexpat -lfreetype -lXft -lmb -lX11 -lXext -lXau -lXdmcp -lpng12" \
+               all install 
+endef
+
+define Package/matchbox/install
+       $(INSTALL_DIR) $(1)/
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+$(eval $(call BuildPackage,matchbox))