luci-0.9: merge r5184-r5189
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 31 Jul 2009 23:36:15 +0000 (23:36 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 31 Jul 2009 23:36:15 +0000 (23:36 +0000)
contrib/package/freifunk-watchdog/Makefile
contrib/package/freifunk-watchdog/src/watchdog.h
libs/cbi/luasrc/view/cbi/lvalue.htm
libs/lucid-http/luasrc/lucid/http/handler/luci.lua
libs/web/luasrc/sauth.lua

index 563b5d0..7a68afb 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freifunk-watchdog
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_BUILD_DEPENDS := uci
index 9c4d557..6d9ccf8 100644 (file)
@@ -66,7 +66,7 @@
 #define WATCH_KEEPALIVE        '\0'
 
 /* System load error action and treshold */
-#define LOAD_TRESHOLD  5.00
+#define LOAD_TRESHOLD  15.00
 #define LOAD_ACTION            "/sbin/reboot"
 
 /* Fallback binary name (passed by makefile) */
index c6b5412..e27948a 100644 (file)
@@ -16,7 +16,7 @@ $Id$
 <% if self.widget == "select" then %>
        <select class="cbi-input-select" onchange="cbi_d_update(this.id)"<%= attr("id", cbid) .. attr("name", cbid) .. ifattr(self.size, "size") %>>
        <% for i, key in pairs(self.keylist) do -%>
-               <option id="cbi-<%=self.config.."-"..section.."-"..self.option.."-"..key%>"<%= attr("value", key) .. ifattr(self:cfgvalue(section) == key, "selected", "selected") %>><%=striptags(self.vallist[i])%></option>
+               <option id="cbi-<%=self.config.."-"..section.."-"..self.option.."-"..key%>"<%= attr("value", key) .. ifattr((self:cfgvalue(section) or self.default) == key, "selected", "selected") %>><%=striptags(self.vallist[i])%></option>
        <%- end %>
        </select>
 <% elseif self.widget == "radio" then
index c54e393..1b452d7 100644 (file)
@@ -26,6 +26,7 @@ Luci = util.class(srv.Handler)
 function Luci.__init__(self, name, prefix)
        srv.Handler.__init__(self, name)
        self.prefix = prefix
+       dsp.indexcache = "/tmp/luci-indexcache"
 end
 
 function Luci.handle_HEAD(self, ...)
index 8ae24a5..41681ab 100644 (file)
@@ -57,7 +57,7 @@ end
 -- @param id   Session identifier
 -- @return             Session data
 function read(id)
-       if not id then
+       if not id or #id == 0 then
                return
        end
        if not id:match("^%w+$") then