Natpmp defaults to expecting iptables to be in /sbin; this patch points it to /usr...
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Oct 2008 19:48:27 +0000 (19:48 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Oct 2008 19:48:27 +0000 (19:48 +0000)
Signed-off-by: Conrad Hirano <openwrt at hirano.fastmail.fm>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12937 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/natpmp/Makefile

index 6f851a3..e355447 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=natpmp
 PKG_VERSION:=0.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://download.savannah.nongnu.org/releases/natpmp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -33,7 +33,7 @@ define Build/Compile
                CC="$(TARGET_CC)" \
                LD="$(TARGET_CC)" \
                CCFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include" \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include" -DIPTABLES_PATH=\\\"/usr/sbin\\\"" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                prefix="$(PKG_INSTALL_DIR)/usr"
 endef