[packages] strace: only change CPPFLAGS when building with an external toolchain...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Apr 2010 19:06:42 +0000 (19:06 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Apr 2010 19:06:42 +0000 (19:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@20961 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/strace/Makefile

index 5b096d2..c1112d8 100644 (file)
@@ -44,9 +44,9 @@ endef
 CONFIGURE_VARS += \
        ac_cv_header_linux_netlink_h=yes
 
-# needed when compiling with an external toolchain
-TARGET_CFLAGS += \
-       -I$(LINUX_DIR)/include
+ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
+endif
 
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"